<!DOCTYPE html>
<html lang="en-US">
<head ><!--[if IE]><![endif]--><link rel="dns-prefetch" href="https://cdn.mlbtraderumors.com" />
<meta charset="UTF-8" />
<title>Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario - MLB Trade Rumors</title><meta name="viewport" content="width=device-width, initial-scale=1" />

		<style type="text/css">
			.slide-excerpt { width: 100%; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { left: 0; }
			.flexslider { max-width: 750px; max-height: 420px; }
			.slide-image { max-height: 420px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> <link rel="alternate" type="application/rss+xml" title="MLB Trade Rumors &raquo; Feed" href="https://www.mlbtraderumors.com/feed" />
<link rel="alternate" type="application/rss+xml" title="MLB Trade Rumors &raquo; Comments Feed" href="https://www.mlbtraderumors.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MLB Trade Rumors &raquo; Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario Comments Feed" href="" />
<link rel="canonical" href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html" />
<link rel="stylesheet" href="https://www.mlbtraderumors.com/wp-content/plugins/thoughtful-comments/css/frontend.css?ver=0.3.5.16.9" type="text/css" media="screen" /><link rel='stylesheet' id='d4p_smashing_tabber-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/d4p-smashing-tabber/tabber.css?ver=4.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='fv_flowplayer-css'  href='https://cdn.mlbtraderumors.com/wp-content/fv-flowplayer-custom/style-5.css?ver=1491904310' type='text/css' media='all' />
<link rel='stylesheet' id='fv-player-pro-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/fv-player-pro/css/style.css?ver=0.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='magazine-pro-theme-css'  href='https://cdn.mlbtraderumors.com/wp-content/themes/mlbtr2015/style.css?ver=20170731.06' type='text/css' media='all' />
<link rel='stylesheet' id='fv_commment_login-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/fv-comment-login/style.css?ver=0.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='swiftype-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/swiftype-search/assets/autocomplete.css?ver=4.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://cdn.mlbtraderumors.com/wp-includes/css/dashicons.min.css?ver=4.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='malinky-ajax-pagination-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/malinky-ajax-pagination/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wppb_stylesheet-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/profile-builder-pro/assets/css/style-front-end.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='fvfacebook-css'  href='https://cdn.mlbtraderumors.com/wp-content/plugins/prettysocial/style.css?ver=1.0.5' type='text/css' media='screen' />
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/d4p-smashing-tabber/tabber.js?ver=4.3.13'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var swiftypeParams = {"engineKey":"TF6gfasNYAHR7xxzRxSy"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/swiftype-search/assets/install_swiftype.min.js?ver=4.3.13'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/themes/mlbtr2015/js/entry-date.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/themes/mlbtr2015/js/responsive-menu.js?ver=1.0.2'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/prettysocial/js/jquery.colorbox-min.js?ver=1.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvfacebook_options = {"url":"https:\/\/www.mlbtraderumors.com\/wp-content\/plugins\/prettysocial\/fv-sharing.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/prettysocial/js/fvfacebook.js?ver=1.0.5'></script>
<link rel='prev' title='Giancarlo Stanton Rumors: Tuesday' href='https://www.mlbtraderumors.com/2017/11/giancarlo-stanton-rumors-tuesday.html' />
<link rel='next' title='NL Central Rumors: Brewers, Iglesias, Reds, Cubs, Davis, Lackey' href='https://www.mlbtraderumors.com/2017/11/nl-central-rumors-brewers-iglesias-reds-cubs-davis-lackey.html' />
  <meta property="og:title" content="Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario" />
  <meta property="og:type" content="blog" />
  <meta property="og:description" content="Some of the same teams to have looked into other free agent first basemen -- the Red Sox, Angels, and Mariners -- have each contacted &amp;hellip;" />
  	<meta property="og:image" content="https://cdn.mlbtraderumors.com/files/2017/11/USATSI_10325437-1024x683.jpg" />
  <meta property="og:url" content="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html" />
  <meta property="og:site_name" content="MLB Trade Rumors" />
  <meta name="twitter:title" content="Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario" />
  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:description" content="Some of the same teams to have looked into other free agent first basemen -- the Red Sox, Angels, and Mariners -- have each contacted &amp;hellip;" />
  <meta name="twitter:image" content="https://cdn.mlbtraderumors.com/files/2017/11/USATSI_10325437-1024x683.jpg" />
  <meta name="twitter:url" content="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html" />
      
<meta property="fb:pages" content="19962522840" />
    <script>
      function fv_more_onclick(id, event) {
        document.getElementById('fv-more-' + id).style.display = 'none';
        document.getElementById('fv-more-text-' + id).style.display = 'block';
      }
    </script>
    <script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":107106,"post_name":"free-agent-notes-duda-tillman-upton-moylan-rosario","post_title":"Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario","post_type":"post","post_author":"16","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":18,"name":"Atlanta Braves","slug":"atlanta-braves","term_group":0,"term_taxonomy_id":18,"taxonomy":"category","description":"Atlanta Braves trade and free agent rumors from MLBTradeRumors.com.","parent":0,"count":3478,"filter":"raw","cat_ID":18,"category_count":3478,"category_description":"Atlanta Braves trade and free agent rumors from MLBTradeRumors.com.","cat_name":"Atlanta Braves","category_nicename":"atlanta-braves","category_parent":0},{"term_id":61,"name":"Baltimore Orioles","slug":"baltimore-orioles","term_group":0,"term_taxonomy_id":61,"taxonomy":"category","description":"Baltimore Orioles trade and free agent rumors from MLBTradeRumors.com.","parent":0,"count":4631,"filter":"raw","cat_ID":61,"category_count":4631,"category_description":"Baltimore Orioles trade and free agent rumors from MLBTradeRumors.com.","cat_name":"Baltimore Orioles","category_nicename":"baltimore-orioles","category_parent":0},{"term_id":28,"name":"Boston Red Sox","slug":"boston-red-sox","term_group":0,"term_taxonomy_id":28,"taxonomy":"category","description":"Boston Red Sox trade and free agent rumors from MLBTradeRumors.com.","parent":0,"count":6549,"filter":"raw","cat_ID":28,"category_count":6549,"category_description":"Boston Red Sox trade and free agent rumors from MLBTradeRumors.com.","cat_name":"Boston Red Sox","category_nicename":"boston-red-sox","category_parent":0},{"term_id":1624,"name":"Chris Tillman","slug":"chris-tillman","term_group":0,"term_taxonomy_id":1624,"taxonomy":"category","description":"","parent":0,"count":58,"filter":"raw","cat_ID":1624,"category_count":58,"category_description":"","cat_name":"Chris Tillman","category_nicename":"chris-tillman","category_parent":0},{"term_id":59,"name":"Los Angeles Angels","slug":"los-angeles-angels","term_group":0,"term_taxonomy_id":59,"taxonomy":"category","description":"Los Angeles Angels trade and free agent rumors from MLBTradeRumors.com.","parent":0,"count":3391,"filter":"raw","cat_ID":59,"category_count":3391,"category_description":"Los Angeles Angels trade and free agent rumors from MLBTradeRumors.com.","cat_name":"Los Angeles Angels","category_nicename":"los-angeles-angels","category_parent":0},{"term_id":484,"name":"Lucas Duda","slug":"lucas-duda","term_group":0,"term_taxonomy_id":484,"taxonomy":"category","description":"","parent":0,"count":67,"filter":"raw","cat_ID":484,"category_count":67,"category_description":"","cat_name":"Lucas Duda","category_nicename":"lucas-duda","category_parent":0},{"term_id":35702,"name":"Melvin Upton","slug":"melvin-upton","term_group":0,"term_taxonomy_id":35700,"taxonomy":"category","description":"","parent":0,"count":23,"filter":"raw","cat_ID":35702,"category_count":23,"category_description":"","cat_name":"Melvin Upton","category_nicename":"melvin-upton","category_parent":0},{"term_id":945,"name":"Peter Moylan","slug":"peter-moylan","term_group":0,"term_taxonomy_id":945,"taxonomy":"category","description":"","parent":0,"count":28,"filter":"raw","cat_ID":945,"category_count":28,"category_description":"","cat_name":"Peter Moylan","category_nicename":"peter-moylan","category_parent":0},{"term_id":41,"name":"Seattle Mariners","slug":"seattle-mariners","term_group":0,"term_taxonomy_id":41,"taxonomy":"category","description":"Seattle Mariners trade and free agent rumors from MLBTradeRumors.com.","parent":0,"count":3654,"filter":"raw","cat_ID":41,"category_count":3654,"category_description":"Seattle Mariners trade and free agent rumors from MLBTradeRumors.com.","cat_name":"Seattle Mariners","category_nicename":"seattle-mariners","category_parent":0},{"term_id":1716,"name":"Wilin Rosario","slug":"wilin-rosario","term_group":0,"term_taxonomy_id":1716,"taxonomy":"category","description":"","parent":0,"count":38,"filter":"raw","cat_ID":1716,"category_count":38,"category_description":"","cat_name":"Wilin Rosario","category_nicename":"wilin-rosario","category_parent":0}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="52333" async></script>    <script type="text/javascript">
      //<![CDATA[
      document.addEventListener("DOMContentLoaded", function(event) {
        jQuery('div.fv_tc_voting').each(function() {
          if( jQuery(this).parents('.fv_tc_voting_box.no-permission').length > 0 ) return;
          
          jQuery(this).click(function() {
            var thisBtn = jQuery(this);
            jQuery('div.fv_tc_voting').fadeTo('fast',0.5);
            if(!thisBtn.hasClass('in_action')) {
              jQuery('div.fv_tc_voting').addClass('in_action');
              jQuery.post(
                "https://www.mlbtraderumors.com/wp-admin/admin-ajax.php",
                { 
                  'action' : 'fv_tc_voting',
                  'postid' : parseInt(thisBtn.data('postid')),
                  'ratetype' : thisBtn.data('ratetype') 
                }, 
                function(response) {  //  todo: use wp_localize_script
                                      var newval = response.split('#');                              
                    thisBtn.parent().find('div.fv_tc_voting_like > span').empty().text('' + parseInt(newval[0]) + '');
                    thisBtn.parent().find('div.fv_tc_voting_dislike > span').empty().text('' + parseInt(newval[1]) + '');
                                    jQuery('div.fv_tc_voting').fadeTo('fast',1);
                  jQuery('div.fv_tc_voting').removeClass('in_action');
                }
              );  
            }                 
          });
        });
      });
      //]]>
    </script>
    <link rel="Shortcut Icon" href="https://www.mlbtraderumors.com/wp-content/themes/mlbtr2015/images/favicon.ico" type="image/x-icon" />
<style type="text/css">.site-title a { background: url(https://cdn.mlbtraderumors.com/files/2017/08/mlbtr-logo-new.png) no-repeat !important; }</style>
<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>

<script type='text/javascript'>
googletag.defineSlot('/5067886/160x600_MLB', [160, 600], 'div-gpt-ad-1397568341242-0').addService(googletag.pubads());
googletag.defineSlot('/5067886/300x250_1_MLB', [[300, 250], [300, 600]], 'div-gpt-ad-1397568341242-1').addService(googletag.pubads());
googletag.defineSlot('/5067886/300x250_2_MLB', [300, 250], 'div-gpt-ad-1397568341242-2').addService(googletag.pubads());
googletag.defineSlot('/5067886/300x250_3_MLB', [300, 250], 'div-gpt-ad-1397568341242-3').addService(googletag.pubads());
googletag.defineSlot('/5067886/728x90_2_MLB', [728, 90], 'div-gpt-ad-1397568341242-4').addService(googletag.pubads());
googletag.defineSlot('/5067886/728x90_MLB', [728, 90], 'div-gpt-ad-1397568341242-5').addService(googletag.pubads());
googletag.pubads().enableSyncRendering();
googletag.enableServices();
</script><!-- ## NXS/OG ## -->
<!-- ## NXS/OG ## -->
</head>
<body class="single single-post postid-107106 single-format-standard custom-header header-image header-full-width content-sidebar" itemscope itemtype="http://schema.org/Blog"><div id="fb-root"></div><script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_EN/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="site-container"><div class="headlines-bar" id="headlines">
  <div class="wrap">
    <div class="news-slider">
      <h3>Headlines</h3>
      <div class="flexslider">
        <ul class="slides">
          <li><a href='https://www.mlbtraderumors.com/2017/11/twins-looking-at-top-tier-free-agent-pitchers.html' target='_blank'>Twins Looking At Top-Tier Free Agent Pitchers</a></li>
<li><a href='https://www.mlbtraderumors.com/2017/11/giants-interested-in-billy-hamilton-reds-rumors-trade.html' target='_blank'>Giants Interested In Billy Hamilton</a></li>
<li><a href='https://www.mlbtraderumors.com/2017/11/braves-to-hire-alex-anthopoulos-as-general-manager.html' target='_blank'>Braves Name Alex Anthopoulos General Manager</a></li>
<li><a href='https://www.mlbtraderumors.com/2017/11/carlos-beltran-announces-retirement.html' target='_blank'>Carlos Beltran Announces Retirement</a></li>
<li><a href='https://www.mlbtraderumors.com/2017/11/all-9-recipients-will-reject-qualifying-offer.html' target='_blank'>All 9 Recipients Will Reject Qualifying Offer</a></li>
<li><a href='https://www.mlbtraderumors.com/2017/11/nippon-ham-fighters-announce-they-will-allow-shohei-otani-to-move-to-majors.html' target='_blank'>Nippon Ham Fighters Announce They Will Allow Shohei Ohtani To Move To Majors</a></li>
        </ul>
      </div>
    </div>
		    <div class="top-socials"><div id="pretty-social-profiles" class="pretty-social-profiles grey"><div class="twitter-profile"><a href="https://twitter.com/mlbtraderumors" class="icon" target="_blank" title="Twitter profile"></a></div><div class="fb-profile"><a href="https://www.facebook.com/MLBTradeRumorscom-19962522840" class="icon" target="_blank" title="FB profile"></a></div><div class="instagram-profile"><a title="Instagram profile" target="_blank" class="icon" href="https://instagram.com/traderumorsmlb/"></a></div>








</div></div>
        <div class="linked-sites"><ul><li class="shorter"><a href="http://hoopsrumors.com/" target="_blank">Hoops <span>Rumors</span></a></li><li><a href="http://profootballrumors.com/" target="_blank">Pro Football <span>Rumors</span></a></li><li><a href="http://prohockeyrumors.com/" target="_blank">Pro Hockey <span>Rumors</span></a></li></ul></div>
	</div>
</div>
    <!--headlines cached @1510695669.7162 saved 0.054286956787109 seconds --><header class="site-header" itemscope itemtype="http://schema.org/WPHeader" id="header"><div class="wrap"><div id="title-area"><p class="site-title" itemprop="headline"><a href="https://www.mlbtraderumors.com/">MLB Trade Rumors</a></p></div><!-- end #title-area --><div class="widget-area"><!-- 728x90_MLB -->
<div id='div-gpt-ad-1397568341242-5' style='width:728px; height:90px;'>
   <script type='text/javascript'>
      googletag.display('div-gpt-ad-1397568341242-5');
   </script>
</div></div><!-- end .widget-area --></div></header><!--explicit cache: /srv/www/traderumors.com/wp-content/themes/mlbtr2015/cache/menu-5.tmp-->
<nav class="nav-secondary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-36951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36951"><a href="/" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-36973" class="teams-item menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36973"><a href="/2010/01/rsstwitter-feeds-by-team.html" itemprop="url"><span itemprop="name">Teams</span></a>
<ul class="sub-menu">
	<!--fv_mlb_teams_menu_new--><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>AL East</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/baltimore-orioles'>Baltimore Orioles</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/boston-red-sox'>Boston Red Sox</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/new-york-yankees'>New York Yankees</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/tampa-bay-rays'>Tampa Bay Rays</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/toronto-blue-jays'>Toronto Blue Jays</a></li>
</ul></li><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>AL Central</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/chicago-white-sox'>Chicago White Sox</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/cleveland-indians'>Cleveland Indians</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/detroit-tigers'>Detroit Tigers</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/kansas-city-royals'>Kansas City Royals</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/minnesota-twins'>Minnesota Twins</a></li>
</ul></li><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>AL West</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/houston-astros'>Houston Astros</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/los-angeles-angels'>Los Angeles Angels</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/oakland-athletics'>Oakland Athletics</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/seattle-mariners'>Seattle Mariners</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/texas-rangers'>Texas Rangers</a></li>
</ul></li><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>NL East</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/atlanta-braves'>Atlanta Braves</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/miami-marlins'>Miami Marlins</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/new-york-mets'>New York Mets</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/philadelphia-phillies'>Philadelphia Phillies</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/washington-nationals'>Washington Nationals</a></li>
</ul></li><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>NL Central</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/chicago-cubs'>Chicago Cubs</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/cincinnati-reds'>Cincinnati Reds</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/milwaukee-brewers'>Milwaukee Brewers</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/pittsburgh-pirates'>Pittsburgh Pirates</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/st-louis-cardinals'>St. Louis Cardinals</a></li>
</ul></li><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a>NL West</a><ul class='sub-menu'><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/arizona-diamondbacks'>Arizona Diamondbacks</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/colorado-rockies'>Colorado Rockies</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/los-angeles-dodgers'>Los Angeles Dodgers</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/san-diego-padres'>San Diego Padres</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58255"><a href='https://www.mlbtraderumors.com/san-francisco-giants'>San Francisco Giants</a></li>
</ul></li><!--/fv_mlb_teams_menu_new-->
</ul>
</li>
<li id="menu-item-36953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36953"><a href="/2008/01/about-mlbtrad-1.html" itemprop="url"><span itemprop="name">About</span></a>
<ul class="sub-menu">
	<li id="menu-item-36954" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36954"><a href="/2008/01/about-mlbtrad-1.html" itemprop="url"><span itemprop="name">MLB Trade Rumors</span></a></li>
	<li id="menu-item-36955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36955"><a href="/2008/01/about-tim-die-1.html" itemprop="url"><span itemprop="name">Tim Dierkes</span></a></li>
	<li id="menu-item-36956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36956"><a href="/2010/03/meet-the-mlbtr-writing-team.html" itemprop="url"><span itemprop="name">Writing team</span></a></li>
	<li id="menu-item-37039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37039"><a href="/2008/05/advertise-on-ml-3.html" itemprop="url"><span itemprop="name">Advertise</span></a></li>
	<li id="menu-item-36960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36960"><a href="https://www.mlbtraderumors.com/archives" itemprop="url"><span itemprop="name">Archives</span></a></li>
</ul>
</li>
<li id="menu-item-36959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36959"><a href="https://www.mlbtraderumors.com/contact" itemprop="url"><span itemprop="name">Contact</span></a></li>
<li id="menu-item-36961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36961"><a href="#" itemprop="url"><span itemprop="name">Tools</span></a>
<ul class="sub-menu">
	<li id="menu-item-106571" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106571"><a href="https://www.mlbtraderumors.com/2017/11/2017-18-top-50-mlb-free-agents-with-predictions.html" itemprop="url"><span itemprop="name">Top 50 MLB Free Agents With Predictions</span></a></li>
	<li id="menu-item-106572" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106572"><a href="https://www.mlbtraderumors.com/2018-mlb-free-agent-tracker" itemprop="url"><span itemprop="name">2017-18 MLB Free Agent Tracker</span></a></li>
	<li id="menu-item-36962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36962"><a href="/2016/08/2017-18-mlb-free-agent-list.html" itemprop="url"><span itemprop="name">2017-18 MLB Free Agent List</span></a></li>
	<li id="menu-item-104471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104471"><a href="https://www.mlbtraderumors.com/2017/10/projected-arbitration-salaries-for-2018.html" itemprop="url"><span itemprop="name">Projected Arbitration Salaries For 2018</span></a></li>
	<li id="menu-item-70391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70391"><a href="http://www.rosterresource.com/mlb-depth-charts/" itemprop="url"><span itemprop="name">MLB Depth Charts</span></a></li>
	<li id="menu-item-37026" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37026"><a href="https://www.mlbtraderumors.com/transactiontracker" itemprop="url"><span itemprop="name">Transaction Tracker</span></a></li>
	<li id="menu-item-37028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37028"><a href="https://www.mlbtraderumors.com/dfatracker" itemprop="url"><span itemprop="name">DFA Tracker</span></a></li>
	<li id="menu-item-37027" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37027"><a href="https://www.mlbtraderumors.com/extensiontracker" itemprop="url"><span itemprop="name">Extension Tracker</span></a></li>
	<li id="menu-item-37025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37025"><a href="https://www.mlbtraderumors.com/agencydatabase" itemprop="url"><span itemprop="name">Agency Database</span></a></li>
	<li id="menu-item-55693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55693"><a href="https://www.mlbtraderumors.com/recent-comments" itemprop="url"><span itemprop="name">Last 100 Comments</span></a></li>
</ul>
</li>
<li id="menu-item-58250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58250"><a href="#" itemprop="url"><span itemprop="name">NBA/NFL/NHL</span></a>
<ul class="sub-menu">
	<li id="menu-item-40340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40340"><a href="https://www.hoopsrumors.com/" itemprop="url"><span itemprop="name">Hoops Rumors</span></a></li>
	<li id="menu-item-40341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40341"><a href="https://www.profootballrumors.com/" itemprop="url"><span itemprop="name">Pro Football Rumors</span></a></li>
	<li id="menu-item-67017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-67017"><a href="http://www.prohockeyrumors.com" itemprop="url"><span itemprop="name">Pro Hockey Rumors</span></a></li>
</ul>
</li>
<li id="menu-item-58251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58251"><a href="https://bnc.lt/get-mlb-trade-rumors" itemprop="url"><span itemprop="name">App</span></a></li>
<li id="menu-item-58252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58252"><a href="/mlbtr-chats" itemprop="url"><span itemprop="name">Chats</span></a></li>
<li class="right search"><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="https://www.mlbtraderumors.com/" role="search"><meta itemprop="target" content="https://www.mlbtraderumors.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="search mlbtr..." /><input type="submit" value="Search"  /></form></li></ul></div></nav>   <div class="nav-arrow nav-arrow_left">
      <a href="https://www.hoopsrumors.com/" target="_blank">
         <span>Go To</span>
         Hoops Rumors      </a>
   </div>
   <div class="nav-arrow nav-arrow_right">
      <a href="https://www.profootballrumors.com/" target="_blank">
         <span>Go To</span>
         Pro Football Rumors      </a>
   </div>
   <!--menu cached @1510693489.4057 saved 0.11719989776611 seconds -->   <div class="nav-arrow nav-arrow_left">
      <a href="https://www.hoopsrumors.com/" target="_blank">
         <span>Go To</span>
         Hoops Rumors      </a>
   </div>
   <div class="nav-arrow nav-arrow_right">
      <a href="https://www.profootballrumors.com/" target="_blank">
         <span>Go To</span>
         Pro Football Rumors      </a>
   </div>
   <div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="main-content-area"><article class="post-107106 post type-post status-publish format-standard has-post-thumbnail category-atlanta-braves category-baltimore-orioles category-boston-red-sox category-chris-tillman category-los-angeles-angels category-lucas-duda category-melvin-upton category-peter-moylan category-seattle-mariners category-wilin-rosario entry" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario</h1> 
<p class="entry-meta">By <a href="https://www.mlbtraderumors.com/author/jeff-todd" title="Posts by Jeff Todd" class="entry-author-link url fn" rel="author"><span itemprop="name" class="entry-author-link entry-author-name">Jeff Todd</span></a> | <time class="entry-time" itemprop="datePublished" datetime="2017-11-14T14:51:52+00:00">November 14, 2017</time> at <time class="entry-time" itemprop="datePublished" datetime="2017-11-14T14:51:52+00:00">2:51pm CDT</time> </p></header><div class="entry-content" itemprop="text"><p>Some of the same teams to have looked into other free agent first basemen &#8212; the <strong>Red Sox</strong>, <strong>Angels</strong>, and <strong>Mariners</strong> &#8212; have each contacted <strong><a href="https://www.baseball-reference.com/players/d/dudalu01.shtml?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener" data-wpel-link="external">Lucas Duda</a></strong> as well, according to Joel Sherman of the New York Post (<a href="https://twitter.com/Joelsherman1/status/930471350216613888" target="_blank" data-wpel-link="external">via Twitter</a>). While he is arguably best served as a platoon option, it&#8217;s worth noting that Duda has generally been quite a productive offensive player and could represent a more affordable target than some other sluggers. The 31-year-old could turn into an excellent value if he&#8217;s able to approach the kind of output he sustained from 2014-15 and also demonstrated in the first half of the 2017 campaign.</p>
<p>Here are some more notes on free agents:</p>
<ul>
<li>Righty <strong><a href="https://www.baseball-reference.com/players/t/tillmch01.shtml?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener" data-wpel-link="external">Chris Tillman</a></strong> will pursue a one-year deal, according to ESPN.com&#8217;s Jerry Crasnick (<a href="https://twitter.com/jcrasnick/status/930508858958712832" target="_blank" data-wpel-link="external">via Twitter</a>). That&#8217;s a sensible strategy for a hurler that had been on track for a nice, multi-year deal before a disastrous 2017 campaign. Tillman, who is still just 29 years of age, dealt with shoulder problems and stumbled to a 7.84 ERA over 93 frames. Still, he seems like a prime target for organizations that need innings and can afford to roll the dice a bit.</li>
<li>Veteran outfielder <a href="https://www.baseball-reference.com/players/u/uptonbj01.shtml" target="_blank" data-wpel-link="external"><strong>Melvin Upton</strong></a> intends to play in 2018, agent Larry Reynolds tells MLB.com&#8217;s Jon Morosi (<a href="https://twitter.com/jonmorosi/status/930144298150039552" target="_blank" data-wpel-link="external">Twitter link</a>). The 33-year-old appeared briefly at Triple-A last year but missed most of the season due to injury. He had enjoyed a renaissance with the Padres in 2015-16 before scuffling upon a mid-season trade to the Blue Jays. It&#8217;s certainly possible to imagine an organization giving him a shot at earning a bench role in camp.</li>
<li>The <strong>Orioles </strong>and <strong>Braves</strong> are interested in righty <strong><a href="https://www.baseball-reference.com/players/m/moylape01.shtml?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener" data-wpel-link="external">Peter Moylan</a></strong>, per MLB.com&#8217;s Mark Bowman (<a href="https://twitter.com/mlbbowman/status/930129957837262848" target="_blank" data-wpel-link="external">via Twitter</a>). Moylan, a 38-year-old Aussie, has befuddled hitters for three years running, compiling a 3.46 ERA with 6.9 K/9 and 3.2 BB/9 over his past 114 1/3 innings since beginning an unlikely comeback. Moylan had <a href="https://www.mlbtraderumors.com/2015/03/braves-peter-moylan-agree-to-minor-league-deal.html" target="_blank" data-wpel-link="internal">signed</a> with the Braves as a minor-league player/coach in 2015; he has excelled all the more since going to the Royals for the ensuing season and led the American League in appearances in 2017. While clubhouse presence is a factor that&#8217;s difficult to assess from the outside, Moylan also promises to make a <a href="http://www.kansascity.com/sports/mlb/kansas-city-royals/article156878254.html" target="_blank" data-wpel-link="external">tangible off-field contribution</a> to whatever team lands him.</li>
<li>There&#8217;s some interest on the market for former Rockies catcher <strong><a href="https://www.baseball-reference.com/players/r/rosarwi01.shtml?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener" data-wpel-link="external">Wilin Rosario</a></strong>, per ESPN.com&#8217;s Jerry Crasnick (<a href="https://twitter.com/jcrasnick/status/930146399760642053" target="_blank" data-wpel-link="external">via Twitter</a>). Still just 28 years of age, Rosario has starred as a first baseman for Korea&#8217;s Hanwha Eagles over the past two seasons. In over one thousand trips to the plate in the KBO, Rosario owns a .330/.390/.625 slash with 70 home runs and just 151 strikeouts. His market will surely be limited since he&#8217;s evidently no longer a real option behind the dish, but the power has always been tantalizing and he ought to be worthy of an opportunity in Spring Training, at the least.</li>
</ul>
<!-- 300x250_2_MLB -->
<div id='div-gpt-ad-1397568341242-2' style='width:300px; height:250px;'>
   <script type='text/javascript'>
      googletag.display('div-gpt-ad-1397568341242-2');
   </script>
</div></div><footer class="entry-footer"><div class='fv_sharing_round'>
<span class="fvfacebook_share"><a onclick="fvfacebook_share_local('.fvfacebook_share .fvshnm','https%3A%2F%2Fwww.mlbtraderumors.com%2F2017%2F11%2Ffree-agent-notes-duda-tillman-upton-moylan-rosario.html'); return false" href="#" title="Share 'Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario' on Facebook"><span>Share</span></a> <span class="fvshnm">0</span></span>
<span class="fvretweet"><a class="image" target="_blank" onclick="pretty_social_increase_number('.fvretweet .twnumber');" href="http://twitter.com/share?url=https%3A%2F%2Fwww.mlbtraderumors.com%2F2017%2F11%2Ffree-agent-notes-duda-tillman-upton-moylan-rosario.html&amp;text=Free+Agent+Notes%3A+Duda%2C+Tillman%2C+Upton%2C+Moylan%2C..." title="Retweet 'Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario' on Twitter"><span>Retweet</span></a> <span class="twnumber">0</span></span>
<span class="fvemail"><a class="image" target="_blank" onclick="prettysocial_email(107106); location.href='https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/email'; return false" href="#" title="Send Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario with an email"><span>Send via email</span></a><span class="emailnumber">0</span></span><div class='fv_sharing_clear'></div>
</div>
<p class="entry-meta"><span class="entry-categories"><a href="https://www.mlbtraderumors.com/atlanta-braves">Atlanta Braves</a> <a href="https://www.mlbtraderumors.com/baltimore-orioles">Baltimore Orioles</a> <a href="https://www.mlbtraderumors.com/boston-red-sox">Boston Red Sox</a> <a href="https://www.mlbtraderumors.com/chris-tillman">Chris Tillman</a> <a href="https://www.mlbtraderumors.com/los-angeles-angels">Los Angeles Angels</a> <a href="https://www.mlbtraderumors.com/lucas-duda">Lucas Duda</a> <a href="https://www.mlbtraderumors.com/melvin-upton">Melvin Upton</a> <a href="https://www.mlbtraderumors.com/peter-moylan">Peter Moylan</a> <a href="https://www.mlbtraderumors.com/seattle-mariners">Seattle Mariners</a> <a href="https://www.mlbtraderumors.com/wilin-rosario">Wilin Rosario</a></span></p><div class="prev-next-navigation"><a href="https://www.mlbtraderumors.com/2017/11/giancarlo-stanton-rumors-tuesday.html" rel="prev">Giancarlo Stanton Rumors: Tuesday</a><a class="main-link" href="/">Main</a><a href="https://www.mlbtraderumors.com/2017/11/nl-central-rumors-brewers-iglesias-reds-cubs-davis-lackey.html" rel="next">NL Central Rumors: Brewers, Iglesias, Reds, Cubs, Davis, Lackey</a></div><!-- .prev-next-navigation --><span class="comments-button"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html#comments" class="comments-link" >9 comments</a></span></footer></article><!--martinv 0-->
<div class='fv_tc_comment_sorting'><a href="#" onclick="location.href = 'https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html?fvtc_order=desc#comments'; return false">newest</a> <span>oldest</span></div><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list"><!--fv comments cache from /srv/www/traderumors.com/wp-content/cache/thoughtful-comments-5/107106-free-agent-notes-duda-tillman-upton-moylan-rosario-desktop-noorder-guest-cpage1.tmp @ 1510696206-->
<!--fv comments cache - START-->

	<li class="comment byuser comment-author-bastros88 even thread-even depth-1" id="comment-1124708">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124708">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/ef7bd1d7fbdb7d1a06e43598df5d8c1f?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/ef7bd1d7fbdb7d1a06e43598df5d8c1f?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">bastros88</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T14:58:03+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124708" class="comment-time-link" itemprop="url" title="November 14, 2017 at 2:58pm CDT" data-fv-time="1510693083">52 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>Peter Moylan would be a great pickup for any team, despite his age he clearly is still reliable and can give teams a great option out of the pen</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124708" data-ratetype="like" title="You must be logged in to vote.">
                  <span>1</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124708" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124708" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	<ul class="children">

	<li class="comment byuser comment-author-johnsilver odd alt depth-2" id="comment-1124722">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124722">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/10c80c0623454c8afecd8248546284ea?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/10c80c0623454c8afecd8248546284ea?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">johnsilver</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:21:04+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124722" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:21pm CDT" data-fv-time="1510694464">29 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>No knocking the guy, but he&#8217;d be a fair back end guy on some teams at a 1y deal and no different than a few others.. such as Blaine Boyer who had decent numbers other than a cpl of blowup games.</p>
<p>Neither will get much other than half a million and Boyer last year had to settle for a MiLB deal and earn his way back to the majors.</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124722" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124722" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124722" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment byuser comment-author-redsox1976 even thread-odd thread-alt depth-1" id="comment-1124720">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124720">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/917fdfc1be413e83de4deba528136577?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/917fdfc1be413e83de4deba528136577?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">redsox 1976</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:20:24+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124720" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:20pm CDT" data-fv-time="1510694424">30 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>Boston need Morrison,Santana or Hosmer! JD Martinez LF wt Nunéz at 2b!! Trade Bradley for prospects and sign a outfield</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124720" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124720" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>1</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124720" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	<ul class="children">

	<li class="comment byuser comment-author-dynamite-drop-in-monty odd alt depth-2" id="comment-1124723">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124723">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/e97b26b9b1b03b0438a51c6601f52235?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/e97b26b9b1b03b0438a51c6601f52235?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">dynamite drop in monty</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:21:42+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124723" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:21pm CDT" data-fv-time="1510694502">28 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>An entire outfield?</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124723" data-ratetype="like" title="You must be logged in to vote.">
                  <span>2</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124723" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124723" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	<ul class="children">

	<li class="comment byuser comment-author-benharvey26 even depth-3" id="comment-1124735">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124735">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/ac9963c3a64ca219ce40b67b9ed93ab0?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/ac9963c3a64ca219ce40b67b9ed93ab0?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">benharvey26</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:42:43+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124735" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:42pm CDT" data-fv-time="1510695763">7 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>Yes&#8211;I think they can get Tropicana&#8217;s turf outfield for an AAV of $4 Million</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124735" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124735" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124735" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment byuser comment-author-bravesfan80 odd alt thread-even depth-1" id="comment-1124721">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124721">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://cdn.mlbtraderumors.com/images/2017/07/IMG_1823-96x96.jpg' class='avatar avatar-80 photo avatar-default' height='80' width='80' /><span itemprop="name">BravesFan80</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:20:56+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124721" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:20pm CDT" data-fv-time="1510694456">29 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>I knew when I saw Moylan’s name as a free agent that the Braves would want him back. I wouldn’t give him more than a one year deal, personally.</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124721" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124721" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>1</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124721" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment byuser comment-author-bringinthereliefpitcher even thread-odd thread-alt depth-1" id="comment-1124728">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124728">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://cdn.mlbtraderumors.com/images/2017/07/Screen-Shot-2017-07-15-at-11.12.07-AM-96x96.png' class='avatar avatar-80 photo avatar-default' height='80' width='80' /><span itemprop="name">bringinthereliefpitcher</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:29:38+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124728" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:29pm CDT" data-fv-time="1510694978">20 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>If the Padres lose Chacin I&#8217;d definitely like to see them pick up Tillman on maybe a 1 year 6 mill contract to eat innings. </p>
<p>Richard and Chacin to eat up innings this year while Lamet, Perdomo, and a 5th guy look to cement themselves as long term options going forward.</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124728" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124728" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>1</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124728" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment byuser comment-author-kingtiger odd alt thread-even depth-1" id="comment-1124732">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124732">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/a42174d8931140d61d0fd4364ac9c418?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/a42174d8931140d61d0fd4364ac9c418?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">KingTiger</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:37:23+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124732" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:37pm CDT" data-fv-time="1510695443">13 mins ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>Tillman is exactly the type of player the Tigers should sign as a scratch ticket.</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124732" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124732" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124732" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment byuser comment-author-houkenflouken even thread-odd thread-alt depth-1" id="comment-1124744">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment" id="div-comment-1124744">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/b4333593bf3131455a34b6205cd2fdae?s=80&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/b4333593bf3131455a34b6205cd2fdae?s=160&amp;d=mm&amp;r=pg 2x' class='avatar avatar-80 photo' height='80' width='80' /><span itemprop="name">houkenflouken</span> 			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-11-14T15:49:46+00:00" itemprop="datePublished"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html/comment-page-1#comment-1124744" class="comment-time-link" itemprop="url" title="November 14, 2017 at 3:49pm CDT" data-fv-time="1510696186">1 min ago</a></time></p><!--fv-->		</header>

		<div class="comment-content" itemprop="text">
			
			 <p>If the mariners get duda, we would probably need to find him a platoon partner, no? </p>
<p>Motter could be it if it was a light platoon.</p>
<div class="fv_tc_wrapper">    <div class="fv_tc_voting_box no-permission">
      <div class="fv_tc_voting fv_tc_voting_like" data-postid="1124744" data-ratetype="like" title="You must be logged in to vote.">
                  <span>0</span><i class="fv-tc-up-arrow"></i>
      </div>
      <div class="fv_tc_voting fv_tc_voting_dislike" data-postid="1124744" data-ratetype="dislike" title="You must be logged in to vote.">
        <i class="fv-tc-down-arrow"></i>          <span>0</span>
              </div>
            <div style="clear:left;"></div>
    </div>
    <div class="reply"><a class="comment-reply-login button login-button" href="#%23comment-1124744" data-wpel-link="internal" target="_blank">Reply</a></div></div>		</div>

		
		
	</article>
	</li><!-- #comment-## -->
<!--fv comments cache - END-->
</ol></div>						<div id="respond" class="comment-respond">
				<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html#respond" style="display:none;">Cancel reply</a></small></h3>
									<p class="must-log-in">Please login to leave a reply. <br /><a class="button login-button" href="#">Log in</a> <a class="button" href="https://www.mlbtraderumors.com/wp-login.php?action=register">Register</a></p>												</div><!-- #respond -->
			    <div class="login-box" style="display: none">
		<form name="loginform" id="loginform" action="https://www.mlbtraderumors.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html#comments" />
			</p>
			
		</form></div>
    <script>
    document.addEventListener("DOMContentLoaded", function(event) {
      jQuery(document).on('click', '.login-button', function(e) {
        e.preventDefault();
        e.stopPropagation();
  
        if( jQuery(this).hasClass('comment-reply-login') ) {
          jQuery('.login-box').insertAfter(this);
          jQuery('.login-box').slideDown();
          var link = jQuery('.login-box').find('input[name=redirect_to]').val();
          var parent_id = jQuery(this).parents('[id]').eq(0).attr('id');
          jQuery('.login-box').find('input[name=redirect_to]').val(link.replace(/#\S+/,'#'+parent_id));
        } else {
          jQuery('.login-box').insertAfter('.must-log-in');
          jQuery('.login-box').slideDown();
          jQuery('.login-box').find('input[name=redirect_to]').val(link.replace(/#\S+/,'#comments'));
        }
      });
    });
    </script>
    <!--martinv 1-->
</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="execphp-3" class="widget widget_execphp"><div class="widget-wrap"><h4 class="widget-title widgettitle">ad: 300x250_1_MLB</h4>
			<div class="execphpwidget">   <div class="center">
      <!-- 300x250_1_MLB -->
      <div id='div-gpt-ad-1397568341242-1'>
      <script type='text/javascript'>
            googletag.display('div-gpt-ad-1397568341242-1');
      </script>
      </div>
   </div>
</div>
		</div></section>
<section id="d4p-smashing-tabber-2" class="widget widget_d4p-smashing-tabber"><div class="widget-wrap"><div class="d4p-tabber-widget"><ul class="d4p-tabber-header"></ul><div id="featured-post-2" class="d4p-st-tab"><a href="#" class="d4p-st-title">Top Stories</a><article class="post-107120 post type-post status-publish format-standard has-post-thumbnail category-greg-holland category-jake-arrieta category-minnesota-twins category-newsstand category-wade-davis category-yu-darvish entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/twins-looking-at-top-tier-free-agent-pitchers.html">Twins Looking At Top-Tier Free Agent Pitchers</a></h2></header></article><article class="post-107079 post type-post status-publish format-standard has-post-thumbnail category-billy-hamilton category-cincinnati-reds category-newsstand category-san-francisco-giants entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/giants-interested-in-billy-hamilton-reds-rumors-trade.html">Giants Interested In Billy Hamilton</a></h2></header></article><article class="post-107015 post type-post status-publish format-standard has-post-thumbnail category-alex-anthopoulos category-atlanta-braves category-newsstand category-transactions entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/braves-to-hire-alex-anthopoulos-as-general-manager.html">Braves Name Alex Anthopoulos General Manager</a></h2></header></article><article class="post-107043 post type-post status-publish format-standard has-post-thumbnail category-carlos-beltran category-houston-astros category-newsstand category-retirement category-transactions entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/carlos-beltran-announces-retirement.html">Carlos Beltran Announces Retirement</a></h2></header></article><article class="post-107030 post type-post status-publish format-standard has-post-thumbnail category-alex-cobb category-carlos-santana category-chicago-cubs category-cleveland-indians category-colorado-rockies category-eric-hosmer category-greg-holland category-jake-arrieta category-kansas-city-royals category-lance-lynn category-lorenzo-cain category-mike-moustakas category-newsstand category-st-louis-cardinals category-tampa-bay-rays category-transactions category-wade-davis entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/all-9-recipients-will-reject-qualifying-offer.html">All 9 Recipients Will Reject Qualifying Offer</a></h2></header></article><article class="post-106836 post type-post status-publish format-standard has-post-thumbnail category-newsstand category-shohei-otani entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/nippon-ham-fighters-announce-they-will-allow-shohei-otani-to-move-to-majors.html">Nippon Ham Fighters Announce They Will Allow Shohei Ohtani To Move To Majors</a></h2></header></article><article class="post-106671 post type-post status-publish format-standard has-post-thumbnail category-giancarlo-stanton category-miami-marlins category-mlbtr-originals category-newsstand entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/assessing-the-trade-market-for-giancarlo-stanton.html">Assessing The Trade Market For Giancarlo Stanton</a></h2></header></article><article class="post-106745 post type-post status-publish format-standard has-post-thumbnail category-arizona-diamondbacks category-jd-martinez category-newsstand entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/jd-martinez-rumor-200-million-asking-price.html">Early Asking Price For J.D. Martinez Reportedly Near $200MM</a></h2></header></article><article class="post-106686 post type-post status-publish format-standard has-post-thumbnail category-newsstand category-roy-halladay entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/roy-halladay-killed-in-plane-crash.html">Roy Halladay Killed In Plane Crash</a></h2></header></article><article class="post-106675 post type-post status-publish format-standard has-post-thumbnail category-newsstand entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/mlbtr-seeking-android-app-developer.html">MLBTR Seeking Android App Developer</a></h2></header></article></div><div id="featured-post-3" class="d4p-st-tab"><a href="#" class="d4p-st-title">Recent</a><article class="post-107106 post type-post status-publish format-standard has-post-thumbnail category-atlanta-braves category-baltimore-orioles category-boston-red-sox category-chris-tillman category-colorado-rockies category-ed-lucas category-los-angeles-angels category-lucas-duda category-melvin-upton category-peter-moylan category-san-diego-padres category-seattle-mariners category-toronto-blue-jays category-wilin-rosario entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/free-agent-notes-duda-tillman-upton-moylan-rosario.html">Free Agent Notes: Duda, Tillman, Upton, Moylan, Rosario</a></h2></header></article><article class="post-107124 post type-post status-publish format-standard has-post-thumbnail category-boston-red-sox category-giancarlo-stanton category-heliot-ramos category-los-angeles-dodgers category-miami-marlins category-san-francisco-giants category-st-louis-cardinals entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/giancarlo-stanton-rumors-tuesday.html">Giancarlo Stanton Rumors: Tuesday</a></h2></header></article><article class="post-107131 post type-post status-publish format-standard has-post-thumbnail category-mlbtr-chats entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/mlbtr-live-chat-312.html">MLBTR Live Chat: Stanton, Free Agents, Braves, Reds, More</a></h2></header></article><article class="post-107054 post type-post status-publish format-standard has-post-thumbnail category-alex-cobb category-boston-red-sox category-carlos-santana category-cleveland-indians category-logan-morrison category-los-angeles-angels category-new-york-mets category-philadelphia-phillies category-seattle-mariners entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/red-sox-rumors-carlos-santana-logan-morrison-angels-mariners.html">Early Markets For Santana, Morrison Taking Shape</a></h2></header></article><article class="post-107107 post type-post status-publish format-standard has-post-thumbnail category-avisail-garcia category-chicago-white-sox category-dayton-moore category-detroit-tigers category-eric-hosmer category-ian-kinsler category-jose-abreu category-kansas-city-royals category-mike-moustakas category-minnesota-twins entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/gm-meetings-notes-the-american-league-central.html">GM Meetings Notes: The American League Central</a></h2></header></article><article class="post-107120 post type-post status-publish format-standard has-post-thumbnail category-greg-holland category-jake-arrieta category-minnesota-twins category-newsstand category-wade-davis category-yu-darvish entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/twins-looking-at-top-tier-free-agent-pitchers.html">Twins Looking At Top-Tier Free Agent Pitchers</a></h2></header></article><article class="post-107089 post type-post status-publish format-standard has-post-thumbnail category-aaron-hicks category-baltimore-orioles category-boston-red-sox category-evan-longoria category-marco-hernandez category-new-york-yankees category-tampa-bay-rays category-toronto-blue-jays entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/al-east-notes-gm-meetings-rays-sellers-rumors-longoria-archer-red-sox-dombrowski-free-agent-hitter.html">GM Meetings Notes: The American League East</a></h2></header></article><article class="post-107067 post type-post status-publish format-standard has-post-thumbnail category-alcides-escobar category-colorado-rockies category-eric-hosmer category-greg-holland category-los-angeles-dodgers category-san-diego-padres category-shohei-otani entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/nl-west-notes-padres-hosmer-alcides-rockies-pen-dodgers.html">NL West Notes: Padres, Hosmer, Alcides, Rockies Pen, Dodgers</a></h2></header></article><article class="post-107100 post type-post status-publish format-standard has-post-thumbnail category-new-york-yankees entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/yankees-to-retain-larry-rothschild-as-pitching-coach.html">Yankees To Retain Larry Rothschild As Pitching Coach</a></h2></header></article><article class="post-107088 post type-post status-publish format-standard has-post-thumbnail category-dominic-smith category-giancarlo-stanton category-jayson-werth category-juan-lagares category-miami-marlins category-new-york-mets category-philadelphia-phillies category-washington-nationals category-wily-peralta entry"><header class="entry-header"><h2 class="entry-title"><a href="https://www.mlbtraderumors.com/2017/11/nl-east-notes-stanton-phillies-mets-needs-nats-werth.html">NL East Notes: Stanton, Phillies, Mets Needs, Nats, Werth</a></h2></header></article></div></div></div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Trade Rumors Apps</h4>
			<div class="textwidget"><div class="center">
   <a href="https://bnc.lt/get-mlb-trade-rumors" ><img class="aligncenter size-full wp-image-42691" src="https://cdn.mlbtraderumors.com/files/2017/08/TradeRumors-AppAd-300x250-new.jpg" alt="Trade Rumors App for iOS and Android"></a>
</div></div>
		</div></section>
<section id="text-5" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">MLBTR Features</h4>
			<div class="textwidget"><h3>MLBTR Features</h3>
<div class="feature">
<ul>
<li><a href="/2017/11/2017-18-top-50-mlb-free-agents-with-predictions.html">Top 50 MLB Free Agents With Predictions</a></li>
<li><a href="/2018-mlb-free-agent-tracker">2017-18 MLB Free Agent Tracker</a></li>
<li><a href="/2016/08/2017-18-mlb-free-agent-list.html">2017-18 MLB Free Agent List</a></li>
<li><a href="/2017/10/projected-arbitration-salaries-for-2018.html">Projected Arbitration Salaries For 2018</a></li>
<li><a href="http://www.rosterresource.com/mlb-depth-charts/">MLB Depth Charts</a></li>
<li><a href="/2016/12/2018-19-mlb-free-agents.html">2018-19 MLB Free Agent List</a></li>
<li><a href="/transactiontracker">Transaction Tracker</a></li>
<li><a href="/dfatracker">DFA Tracker</a></li>
<li><a href="/extensiontracker">Extension Tracker</a></li>
<li><a href="/agencydatabase">Agency Database</a></li>
<li><a href="http://twitter.com/mlbtraderumors">MLBTR On Twitter</a></li>
<li><a href="http://www.facebook.com/pages/MLBTradeRumorscom/19962522840">MLBTR On Facebook</a></li>
<li><a href="/2010/06/team-and-transactiononly-feeds.html">Team Twitter/RSS Feeds</a></li>
<li><a href="/2010/11/team-facebook-pages.html">Team Facebook Pages</a></li>
<li><a href="https://www.hoopsrumors.com/">Hoops Rumors</a></li>
<li><a href="https://www.profootballrumors.com/">Pro Football Rumors</a></li>
<li><a href="https://www.prohockeyrumors.com/">Pro Hockey Rumors</a></li>
<li><a href="http://www.rosterresource.com/">Roster Resource</a></li>
</ul>
</div></div>
		</div></section>
<section id="text-13" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">FB</h4>
			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/MLBTradeRumorscom-19962522840" data-width="290" data-height="240" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"></div></div>
		</div></section>
<section id="text-14" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><h3>Rumors By Team</h3>

<ul><li><a href="/los-angeles-angels">Angels Rumors</a></li>
<li><a href="/houston-astros">Astros Rumors</a></li>
<li><a href="/oakland-athletics">Athletics Rumors</a></li>
<li><a href="/toronto-blue-jays">Blue Jays Rumors</a></li>
<li><a href="/atlanta-braves">Braves Rumors</a></li>
<li><a href="/milwaukee-brewers">Brewers Rumors</a></li>
<li><a href="/st-louis-cardinals">Cardinals Rumors</a></li>
<li><a href="/chicago-cubs">Cubs Rumors</a></li>
<li><a href="/arizona-diamondbacks">Diamondbacks Rumors</a></li>
<li><a href="/los-angeles-dodgers">Dodgers Rumors</a></li>
<li><a href="/san-francisco-giants">Giants Rumors</a></li>
<li><a href="/cleveland-indians">Indians Rumors</a></li>
<li><a href="/seattle-mariners">Mariners Rumors</a></li>
<li><a href="/miami-marlins">Marlins Rumors</a></li>
<li><a href="/new-york-mets">Mets Rumors</a></li>
<li><a href="/washington-nationals">Nationals Rumors</a></li>
<li><a href="/baltimore-orioles">Orioles Rumors</a></li>
<li><a href="/san-diego-padres">Padres Rumors</a></li>
<li><a href="/philadelphia-phillies">Phillies Rumors</a></li>
<li><a href="/pittsburgh-pirates">Pirates Rumors</a></li>
<li><a href="/texas-rangers">Rangers Rumors</a></li>
<li><a href="/tampa-bay-rays">Rays Rumors</a></li>
<li><a href="/boston-red-sox">Red Sox Rumors</a></li>
<li><a href="/cincinnati-reds">Reds Rumors</a></li>
<li><a href="/colorado-rockies">Rockies Rumors</a></li>
<li><a href="/kansas-city-royals">Royals Rumors</a></li>
<li><a href="/detroit-tigers">Tigers Rumors</a></li>
<li><a href="/minnesota-twins">Twins Rumors</a></li>
<li><a href="/chicago-white-sox">White Sox Rumors</a></li>
<li><a href="/new-york-yankees">Yankees Rumors</a></li>
</ul></div>
		</div></section>
<section id="execphp-4" class="widget widget_execphp"><div class="widget-wrap"><h4 class="widget-title widgettitle">ad: 160x600_MLB</h4>
			<div class="execphpwidget"><div class="center">
      <!-- 160x600_MLB -->
      <div id='div-gpt-ad-1397568341242-0' style='width:160px; height:600px;'>
         <script type='text/javascript'>
            googletag.display('div-gpt-ad-1397568341242-0');
         </script>
      </div>
</div></div>
		</div></section>
<!--sidebar cached @1510695535.1801 saved 0.63483905792236 seconds --></aside></div><div class="before-footer"><!-- 728x90_2_MLB -->
<div id='div-gpt-ad-1397568341242-4' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.display('div-gpt-ad-1397568341242-4');
</script>
</div></div></div><div class="footer-widgets"><div class="wrap"><div class="footer-widgets-1 widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Navigation</h4>
<div class="menu-footernavigation-container"><ul id="menu-footernavigation" class="menu"><li id="menu-item-60254" class="menu-item  menu-item-type-post_type menu-item-object-page menu-item-60254"><a href="https://www.mlbtraderumors.com/sitemap">Sitemap</a></li>
<li id="menu-item-37034" class="menu-item  menu-item-type-post_type menu-item-object-page menu-item-37034"><a href="https://www.mlbtraderumors.com/archives">Archives</a></li>
<li id="menu-item-37052" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37052"><a href="/2010/01/rsstwitter-feeds-by-team.html" itemprop="url">Feeds by Team</a></li>
</ul></div></div></section>
</div><div class="footer-widgets-2 widget-area"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">MLBTR INFO</h4>
<div class="menu-mlbtr-info-container"><ul id="menu-mlbtr-info" class="menu"><li id="menu-item-37043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37043"><a href="/2008/05/advertise-on-ml.html" itemprop="url">Advertise</a></li>
<li id="menu-item-37044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37044"><a href="/2008/01/about-mlbtrad-1.html" itemprop="url">About</a></li>
<li id="menu-item-37045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37045"><a href="/2012/01/commenting-policy.html" itemprop="url">Commenting Policy</a></li>
<li id="menu-item-37046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37046"><a href="/2007/08/mlbtraderumorsc.html" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
</div><div class="footer-widgets-3 widget-area"><section id="nav_menu-4" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Connect</h4>
<div class="menu-connect-container"><ul id="menu-connect" class="menu"><li id="menu-item-37047" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37047"><a href="/contact.html" itemprop="url">Contact Us</a></li>
<li id="menu-item-37049" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37049"><a href="http://www.twitter.com/mlbtraderumors" itemprop="url">Twitter</a></li>
<li id="menu-item-37050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37050"><a href="http://www.facebook.com/pages/MLBTradeRumorscom/19962522840" itemprop="url">Facebook</a></li>
<li id="menu-item-37051" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37051"><a href="/feed" itemprop="url">RSS Feed</a></li>
</ul></div></div></section>
</div></div></div>
	<div class="site-footer"><div class="wrap"><p><a href="https://www.mlbtraderumors.com" title="MLB Trade Rumors">MLB Trade Rumors</a> is not affiliated with Major League Baseball, MLB or MLB.com</p><a class="hide-arrows" href="#">hide arrows</a><a class="fox-badge" href="http://www.foxsports.com/"><img width="100" height="50" alt="FOX Sports Engage Network" src="https://cdn.mlbtraderumors.com/wp-content/themes/mlbtr2015/images/badge_100.gif" style="border: 0"></a><a class="to-top-button" href="#header">scroll to top</a></div></div>
<!--footer cached @1510693490.5015 saved 0.049851894378662 seconds --></div><input type="hidden" id="ct_checkjs_30ef30b64204a3088a26bc2e6ecf7602" name="ct_checkjs" value="0" /><script type="text/javascript">setTimeout(function(){    var ct_input_name = 'ct_checkjs_30ef30b64204a3088a26bc2e6ecf7602';    if (document.getElementById(ct_input_name) !== null) {        var ct_input_value = document.getElementById(ct_input_name).value;        document.getElementById(ct_input_name).value = document.getElementById(ct_input_name).value.replace(ct_input_value, '1956308707');     }}, 1000);</script><div id='touch_three_desktop_switch' style='display:none'>
<div class="wptouch-desktop-switch" style="position: static; z-index:1000; padding-top: 10px; padding-bottom: 40px; font-size: 120%; text-align: center; font-weight: bold; line-height: 150%">
	Desktop Version | <a onclick="window.location = 'https://www.mlbtraderumors.com?wptouch_switch=mobile&amp;redirect=%2F2017%2F11%2Ffree-agent-notes-duda-tillman-upton-moylan-rosario.html&amp;nonce=db33724e4c'" href="#" rel="nofollow">Switch To Mobile Version</a>
</div></div>
<script type='text/javascript'>
if( document.cookie.match(/wptouch-pro-view=desktop/) ) document.getElementById('touch_three_desktop_switch').style.display = 'block';
</script>
<!-- Powered by WPtouch Pro: 1.1.3 --><script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",slideDirection: "vertical",animation: "slide",directionNav: 1,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000,slideshow: false    });  });</script><script type="text/javascript">
              if(typeof ajaxurl == "undefined"){
                var ajaxurl = "https://www.mlbtraderumors.com/wp-admin/admin-ajax.php"
              }
            
              document.addEventListener("DOMContentLoaded", function(event) { jQuery("#fv-comment-plus-subscribe").click( function(){
                    jQuery("#subscribe-comment-wrap").show();
                  });
                  
                  jQuery("#fv-comment-plus-subscribe-submit").click( function(){
                    
                    var postID = 107106;
                    var name = jQuery("#fv-comment-plus-name").val();
                    var email = jQuery("#fv-comment-plus-email").val();

                    if( name == undefined || name == "" ){
                      alert("Please enter your name.");
                      return false;
                    }
                    
                    if( email == undefined || !fv_cps_validate_email(email) ){
                      alert("Please enter correct email address.");
                      return false;
                    }
                    
                    jQuery("#fv-comment-plus-subscribe-submit").attr("disabled", true);;
                    
                    fv_comment_plus_subsription(postID, name, email);
                  });});
              
              function fv_cps_validate_email(email) {
                var re = /^([\w-]+(?:\.[\w-]+)*)@((?:[\w-]+\.)*\w[\w-]{0,128})\.([a-z]{2,63}(?:\.[a-z]{2})?)$/i;
                return re.test(email);
              }
              
              
              function fv_comment_plus_subsription( postID, name, email ){
                jQuery("#fv-comment-plus-notice").prepend('<img  src="https://cdn.mlbtraderumors.com/wp-admin/images/loading.gif" /> ');
              
                var data = {
                  action: "comment_plus_subscribe",
                  postID: postID,
                  name: name,
                  email: email,
                  _nonce: "868f3d8d17"
                };

                jQuery.post(ajaxurl, data, function(response) {
                  jQuery("#fv-comment-plus-notice").html(response);
                });
              }
              
            </script><script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/www.mlbtraderumors.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.3'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-includes/js/comment-reply.min.js?ver=4.3.13'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var malinkySettings = {"1":{"theme_defaults":"Twenty Sixteen","posts_wrapper":"#main-content-area","post_wrapper":".post","pagination_wrapper":".pagination","next_page_selector":".pagination-next a","paging_type":"load-more","infinite_scroll_buffer":"20","ajax_loader":"<img src=\"https:\/\/www.mlbtraderumors.com\/wp-content\/plugins\/malinky-ajax-pagination\/img\/loader.gif\" alt=\"AJAX Loader\" \/>","load_more_button_text":"Load More Posts","loading_more_posts_text":"Loading...","callback_function":""}};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/malinky-ajax-pagination/js/main.js'></script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/fv-js-post-time/fv-js-post-time.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fv_player_lightbox = {"lightbox_images":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/fv-wordpress-flowplayer/js/lightbox.js?ver=6.0.5.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvt_lite_noajax = {"post_id":"107106"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.mlbtraderumors.com/wp-content/plugins/fv-tracker-lite/js/cookie-post-tracker.dev.js?ver=1.1.11.1'></script>
      <script type='text/javascript'>
         document.addEventListener("DOMContentLoaded", function(event) { 
            jQuery(".fv_fblikebox_button").colorbox({width:"360px", height:"130px", iframe:true });
         });
      </script>
      <!-- NEW -->
<!-- Begin comScore Tag -->
<script type="text/javascript">
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035210" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img alt="comscore" src="https://b.scorecardresearch.com/p?c1=2&amp;c2=6035210&amp;cv=2.0&amp;cj=1" />
</noscript>
<!-- End comScore Tag -->
<!-- End NEW -->

<!--<script src="https://network.yardbarker.com/network/ybn_pixel/13237" type="text/javascript"></script> <noscript></noscript>-->

<!-- Twitter universal website tag code -->
<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nw53h');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->
<script>
              (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
              (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
              m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
              })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
            
              ga('create', 'UA-1004551-1', 'auto');
              ga('send', 'pageview');
            
            </script>

</body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1510696423 -->